Beast Lightmapping issue

I’m testing the Beast Lightmapping feature on Unity but some weird shadows are appearing in the wrong place. My best guess is that, since some objects will have the same texture, I’ve shared their UVs on the layout, and that’s causing the problem, they are sharing the shadows too! Is there a way to fix this? Having sereval UVs for the same objects it’s impossible, since the scene will have hundreds of this.alt text

Do you have Generate Lightmap UV’s checked in the mesh import settings?