Beast Lightmapping - No shadows when doing "Bake Selected"

So this is getting very annoying and I can’t find a way around it…my scene is setup with a ground plane, 2 houses, and 4 spot lights. All the objects are marked as ‘static’, and all the spotlights have hard shadows turned on.

If I bake everything at once, the house cast shadows on the ground plane, but if I only select the ground plane, and do a ‘Bake Selected’, then the houses don’t cast shadows on the ground plane anymore, and no AO is baked in where they meet the ground. I would think that as long as the houses are marked ‘static’, that Beast would take them into consideration when baking lightmaps even if they’re not selected when doing a ‘Bake Selected’, so that you can still get their shadows and AO!

Is there way around that? If not, then the ‘Bake Selected’ option seems pretty useless to me…dunno, maybe I’m missing something?

Thanks for your time!

Well, it’s only doing what you’re asking it to do. Since you’ve only selected the ground, that’s the only thing that’s taken into account. It shouldn’t use anything marked static that’s not selected, because if it’s just going to use everything anyway, that would defeat the purpose of “bake selected” (namely, to do quick test renders on whatever’s selected).

"Well, it’s only doing what you’re asking it to do. "

Same attitude like when I suggested that Blender should ask for saving when someone hits ‘QUIT’. Yes, technically it does what you say, but all other apps I used before was able to bake the selection with received shadows, so it is quite logical to make it that way.