Best Android API Level

What should my target be for this? I want to make sure I support most mid-range phone/tablets from the last couple years.

Any advice is appreciated! Thank you

Check this link about uses-sdk from Android Developers.

Unity supports Android version 2.3 (API Level 9) and above so that becomes your minSdkVersion.

Now for targetSdkVersion if you specify nothing then Android will use minSdkVersion as targetSdkVersion. So consider your targetSdkVersion to be API level 9.

And for mid-range phone/tablets as they mostly use Android version 2.3 (Gingerbread) then you should not have a problem with that. So you are good to go.

But if you still want to go down and provide support for version below 2.3 then I’m afraid it is not possible since Unity 4 they have deprecated the support for those versions below 2.3.

Exactly what I needed to know! Cheers