black lines, if mesh is really huge


i am working on a city generator. Therefor i have a grid of 100x100 Meshes. Every Mesh is 1x1 Unit big.

My problem is, that a few units away of the camera a lot of black lines appear. Its not the fault of my graphics card. (I tested on other machines)

alt text

I’m using the standard shader an no image effect. I tested all camera and texture properties… (The lines sometimes changed a bit, but the never disappeared)

alt text
alt text
alt text
alt text

Does someone has any ideas how to fix that?

Thank you!

I think it has nothing to do, with the fact that i use multiple meshes.
For the following screenshot i only spawned one primitive cube, scaled every coordinate up to 1000, and moved the camera near the cube
alt text

Ok, i found a solution:

**Edit: **
before you try the following steps, set the rendering path in your camera to deffered…
This should help in the most cases.

To remove the lines in far distance, i apllied the following texture settings:

alt text

(you can use a different filter setting, but i need point-filtering because i use a pixel-texture)

For the remaining lines, i only found a workaround:
Add the Global Fog Image Effect to the Camera.
alt text

To remove the circular lines, you have to increase the bias (not normal bias) setting in your directional lights.
alt text

Sometimes, you can see lines where one tile touches another tile.
To fix that i combined my tile-meshes to chunk-meshes:

alt text

Note that the lines are still there, but you can only see them sparkling between two chunks (and not between every tile).
Also it may help, if you set ‘Alpha from Grayscale’ and ‘Alpha is Transparency’ to true.