Black Screen when building for Oculus Quest

Hi guys, hoping you can help me out. I'm trying to build an app for Oculus Quest. I'm able to successfully build the APK and push it to the device. When I start it up, a black rectangle appears in the middle of the Oculus Home environment and doesn't open up into the full app. I can hear the audio though.

I'm on Unity 2018.4.9f1, unfortunately, I'm not able to use any other version right now. I have the Oculus integration package and I have the Oculus VR SDK enabled in the player settings. I'm targeting Android API level 25 and get no significant build errors. Not sure what's going wrong here.

Update: If i take the headset off and put it back on, I can see the app. But it still opens in a box and not in VR.

Update, just tried on the most recent version of Unity 2018 LTS. Same exact problem.

I just tried updating my Oculus Integration and started having the same issue. After reverting the problem goes away. No clue what in the integration is causing it.

I noticed a few days ago that Oculus had just done one of their "invisible, background, you get no choice we're forcing this on you" updates of the drivers. Are you on the new driver versoin (15.0 - should be visible in the Oculus desktop app, and on the Quest's settings in-world - although it can be different versions on each) - and did this start at same time as the update completed?

(I haven't done any builds with the new drivers yet, but it immediately made me suspicious :))

Hi Nomadic,
Could you share the process for reverting it back? I just did my very first build and am experiencing a similar issue as dcrouchelli.

1 Like

@MShotts

Well sadly it seems Oculus has moved all of their Unity integrations to the Asset Store and you can't download older versions from the developer portal like you used to. Luckily for me I had an older version in source control.

You can try poking around here: https://developer.oculus.com/downloads/package/unity-integration/ but I'm pretty sure all download links point to the same asset store page which only has one release version. It's really frustrating especially if there is in fact a regression in the integration causing this issue.

1 Like

@nomadic

Your link was spot on! Previous versions are tucked away on the 'Unity Integration Archive'. Right underneath the title is the version number as well as a down arrow. Clicking the down arrow pulls up all the previous versions for selection. I'll try 14.0 and hopefully that resolves the issue.

Thanks again!

Unfortunately, going to 14.0 did not resolve the issue for me.

I attempted to use the 'OVR Build and Run' which resulted in errors indicating my Android SDK was not found. I followed the advice of the 2 threads below and installed Android Studio rather than rely on the Unity versions. I updated the paths under Edit->Preferences->External Tools but then got errors about the Gradle (only with OVR Build and Run). I installed Gradle as well and updated the path but consistently had build fails with both Unity and OVR 'Build and Run' due to the Gradle install not being 'valid'. I haven't yet found a way to make it valid.

It's not likely that I've made any meaningful advancements in resolving this issue but I'm documenting it so others can avoid (or perhaps also go down) this rabbit hole.

Android SDK Not Found
https://discussions.unity.com/t/762184
https://discussions.unity.com/t/760419

Installing Gradle
https://discussions.unity.com/t/736308

Just to document more steps I took which also failed to resolve the issue:

  • Under Project Settings->Player->Other Setttings, I updated the 'Minimum API Level' to Level 23. I found this recommendation in the comments for Andrew in VR's video on the Unity XR Interaction Toolkit.
  • Under Project Settings->Player->XR Setttings, I switched from Multi to Single Pass.
1 Like

Aaaaand, I just realized that I'm a moron. I did not have the Oculus SDK enabled under Project Settings->Player->XR Settings. The build ran fine once I enabled 'V2 Signing (Quest)'.

5 Likes


This fixed it for me.
I was confused because my flow was:
-Working fine
-Tried tinkering with VRToolKit
-Not working.

I guess VRTK or maybe another imported asset reverted my SDK settings.

I still have this issue. Oculus SDK 18 (tried 17 and didnt work). Unity 2019.4.6f (latest LTS). Everything compile and even run under Link/PC. But when the apk is generated for android and sent to the quest it displays a black screen.

1 Like

I'm having this issue right now on a new project using SDK 18 with Unity 2019.3.15f1. Yet I can use SDK 18 on a pre-existing project and it works fine. I've tried making the project settings, packages and assets store installs all match between projects. But I still can't figure out what it is that makes the old one work and the new project give me a black screen.

This project was just created using the "3D" project type, and not using any LWRP or URP.


I have same issue, have you found a way to fix this yet? Thank you in advance.

Try Oculus -> Tools -> Create store-compatible AnroidManifest.xml

2 Likes

Was using Unity 2019.4.2f1 and updated it to 2019.4.7f1 (newest LTS) and my build works perfect. I've debugged for 2 days trying to build. I hope this advice helps somebody :smile:!

2 Likes

Had the same issue and this is the fix, I updated Unity and no more issues

Me too! It seems that when you first check the checkbox it downloads a bunch of stuff but doesn't enable it.

I had this same problem where it'd successfully build, but then wouldn't appear in my Oculus Quest headset.

I found that having the Quest plugged into my laptop whilst building and then unplugging it once built worked and my build finally ran in my headset.

Hopefully this works for you!

I followed this tutorial on how to set-up the headset with Unity: https://circuitstream.com/blog/oculus-quest-unity-setup/