Black spots in terrain

My terrain has black spots in some places when i zoom in they get smaller when i zoom out it gets bigger can someone please help me NOTE: im using a pc build not mobile

Sounds like they are clipping out of the camera’s draw distance.

Increase far clipping plane distance.

Alternatively, reduce the scale of everything. That way everything will look the same but you will probably be within the camera clipping plane.

Did you ever figure this out? I am having the same issue.

Hey, I found a fix. Respond if you’re still there.

Can be the cause of many simple bugs but try these:

On the terrain component go to options and untick cast shadows.

Make sure no other objects are clipping the terrain.

Make sure you’re not using a broken heightmap