Black stripes shadows

Hello, I add a point light with hard shadow and i get black stripes on walls when it’s on in low resolution shadow, so i search how remove them or reduce. Thanks.

Image : Screenshot by Lightshot

Try tweaking the shadow bias value in your light.

I get the same problem when there is a very small angle between the plane and the light.
The only solution that I found was to turn off shadow casting for the object.

It’s a bit sad that no one from unity has answered this question in over a year.
Do they not care about their paying customers?

Thanks a bunch Louis.

It so happens that I’m lighting the large rounded corner of a building with directional sunlight that needs to be on one side and not the other for narrative reasons…

But I guess I’ll have to think of a different architecture or something :wink:

If anyone stumbles across this in 2018+ , in your directional light under “shadows” try increasing the resolution. It will get rid of banding on steep angles.