Blank "Unity Launch Error" when attempting to open or create any projects whatsoever

I recently redownloaded Unity having previously not used the Hub, however I also upgraded to Windows 11, and I have no idea if that somehow affected my ability to run the program.

Any time I try to create a new project in the Hub, I get a blank launch error. If I try to open the project it creates it tells me that it failed. No fixes I have found online have helped me. I’ve tried to reinstall Unity multiple times over various versions, same with Unity Hub. I’ve tried messing with admin permissions, changing folders, fixing Visual Studio, absolutely nothing seems to work and I’m just so confused as to what could be going on.

I will provide a screenshot of the error I get, I know it won’t be much help at all, but if anyone can help me out in any way I would really appreciate it, thank you in advance.

I’m having the exact problem with my desktop, no matter what i try i still get the error (only solution i’ve found is to use the editor without the hub), however the hub and editor works on my laptop as it should… Would love to get a proper fix for this problem.

Got the same problem today… I was not using unity for a week… I tried today to open a project Ive creat at 03/22 and I got this same problem.

Tried to reinstal everything, Unity, Hub, Visual Studio… Anything works

I also cant create new projects. I got the same error everytime

I think I have found a similar thread that DID come up with a solution (seemingly, at least). The solution they found was to rollback to an older version of Unity Hub. It might be a good solution to try while you wait for an official patch.

Original thread:

Link for Unity Hub 2.0: Dropbox - UnityHubSetup-2.0.4.exe - Simplify your life

Hope this helps!

Hi All who still facing this issue, I MAYBE found a solution.

Same issue happened to me, I tried the downgrading hub way too but it still won’t open, then I realised that I’ve set to Unity Editor “launch as administrator” day before, since I’ve unchecked it, Hub started to working normaly as before.

So maybe check or uncheck will fix it, I hope it will work for you as for me! Leave me comment pls if it doesn’t work for you! TY!

Found a fix for me. I had set Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Null\Start to 4. Set it back to 2 and the issue should be fixed

Same problem for me too. I got lucky by cancel unity lunch as a admin.