Blend Tree wont play a motion field

Hello. I have a blend tree with four motion fields in it. It uses a float as a parameter that goes between 0 and 1.5

The first three motion fields work perfectly when the parameter is at 0, 0.5, or 1.0, however when I set the parameter to 1.5 it will not play the animation in the fourth motion field.

I tried changing the fourth motion field to a different animation and it worked, so it must be an issue with the animation itself. However the animation clip is working fine when I try to preview it in the inspector. Any ideas?

After playing around a little, it seems the animation clip just doesnt work at all. I tried playing the animation in the base layer with no avatar mask, and there is still no change. Its as if the animation is just an empty state. However the animation still looks fine when I preview the clip in the inspector.

I had a similar problem, I solved it by changing Blend Type from 2D simple Directional to 2D Freeform Directional. For difference between the two check this link Controlling Animation