Blender FBX Mesh not present

Hello everyone. I’m fairly new to this Question thingy, but here it goes:

I’ve already modeled, textured, rigged and animated a simple model in Blender 2.68a. I’ve both imported it as a .blend and as a .fbx file into Unity (4.3.2f1) and while the animations and armature do show up, the mesh doesn’t. I’ts just not in the asset’s group. If I put next to the model in the .blend file a cube or anyhting it does go through on Unity. Anything except the model. The Normals are well, the mesh doesn’t have any holes, and all the doubles have been removed. The scale is also 1. I belive maybe the model has something invalid? Any help is appreciated, thank you beforehand for putting up with this.

Most of the time I import a mesh from Blender to Unity (by just dragging the “.fbx” file in the project folder. I also notice that i have to change some settings to let it work with Unity.

If you can’t see the mesh, you have to make sure it is big enough. It sounds stupid but when I export my blender file to unity it always seems to have a scalefactor of 0.01, change this to like whatever you prefer (just play around withit)

If that didn’t work another option is just to highlight it in the hierarchy and go with your mousecursor to the scene en press “F”. Unity will zoom in the selected mesh. update : you can also just double click in the hierarchy to let it zoomin

You also mention that there are objects going through the imported mesh. To fix this you just have to let it generate a collider.

Here is a picture, I hope this can help you out.

: