Blender import animation to Unity, source take section missing

Hello my fellow friends. First I apologize for my bad English writing as long as English isn’t my main language. After setting up Rigify and made some animations, save as .blend file, switch to Unity, and I only have 1 animation which is “Default Take”. And I cannot find any source take. From Unity Manual, I found that when there is only 1 animation, source take will not show up. I made the animation with dope sheet action editor in Blender. After done an animation I click the F button beside the animation name. When I want to add a new animation, I use the + button which beside the F button. And there is a “2” button show beside the F button. Image as shown as below. (Sorry there should only have 2 animations but because of I keep trying to solve the problem and causing the animation duplicated)

46823-capture.png

I do some research from google but there are suggesting to export as FBX, but I hope there is a solution for .blend file. As you can see the source take didn’t show up and that “+” button is not working at all, it just create another animation which is same as the first one.

46861-2.png

I am using Unity 5.0.0f4 and Blender v2.74. Any help are welcome :slight_smile:

I came across the same issue where I didn’t have a “source take” option when importing animations from a .blend file. I duplicated a working .blend file and started making incremental changes to it until it broke, and in my case the issue was that I had bones that had been deleted, but they were still referenced by some animation actions in the .blend file. It seems that having orphaned channels in your animation actions breaks the whole file when you import it to Unity (instead of just ignoring those channels).


The solution is to delete all references to those bones in all of your actions in the action editor, and the “source take” drop down should come back. You can do that in Blender by:

  1. Opening the action in the action editor
  2. Selecting all bones in the viewport (so you can see keyframes for all bones/channels)
  3. Filtering for the bones you deleted using the search box at the top of the channel list
  4. Highlighting the channels for all deleted bones using shift + click
  5. Press ‘X’ on the keyboard to delete them
  6. Save and re-import to Unity

If you’ve already deleted the bones I don’t know if there’s a way to see the channels for those bones (since you cannot select them in the 3D viewport). The best way around that is to select all of the bones that still exist, then select all of the keyframes for those bones and copy them to a new action. Then you can delete the old action (containing the inaccessible orphaned references) in the outliner window (where the scene hierarchy usually is) by changing the display mode to from “Scenes” to “Blender File”->expand the “Actions” node->right-click the action->delete.


This is the process that worked for me—hopefully it can help someone else in the future.

To clear those duplicate, just save the blend file, and reload it. Then all you’ll have left are the animations with the F. Yes, I would suggest exporting it in FBX, and I generally like to use ASCII, instead of Binary. You don’t need a Default Take either.

I had the same issue. In my case solved the problem by adding a new clip to the list (click the + button at the botton of the clips list) and chose the source take in the drop down menu (just below the clips list). Sorry for the english. I´m not a native speaker.

just import it. thanks