Blender Model acting weard

I have modeled a spacecraft in blender when I i finished I followed the directions I found on the interent to reset it Location, roation, and scale. Then it said you had to apply and -90 degree rotation to it and apply this to get the collison mesh in unity to line up with it. When I bring it into Unity like this the collsion works great but if I move my model from the 0, 0, 0 location when I press play it instantly jumps back to this location. I cant seem to find out why?

you should rotate the model IN BLENDER, on whatever axis, then try it again. It happened to me too :stuck_out_tongue:

I’m using Unity 3.5.6 with Blender 2.6.4 and I’ve noticed that when I created a static (non-animated) Blender model, it for some reason suddenly jumps to another position when I hit play.

I’ve baked all transforms in Blender (Edit mode, Ctrl+A) and it still happened.

There are two workarounds to that:

  1. Add an Armature to the model in Blender with a neutral root bone and parent the mesh to it. Pretty wasteful since no animation will be happening at all.
  2. Instead of the Armature, adjust the import settings in Unity: select the model in the Project pane, find the “Animations” group and pick “Don’t Import.”

YO!

Select the imported object and look in the inspector, under ‘Animations - Generation’ select ‘Dont import’.

Then drag the object into your scene, check that anything to do with animations is turned off.

I had this problem my self when i started, this sorted it out :slight_smile: