Blender model missing polygons

Image of the issue (Unity on the left, Blender on the right) I made a temp model in blender and then textured it poorly. When I put it into Unity, random polygons are just missing? I dont really know whats going wrong here, I looked on google and read that it might be “backface culling” or something, but Im not seeing how to enable anything like that on unity or blender (because of blenders new layout, I cant find anything). Anyone know how to fix this? Any help would be greatly appreciated.

Backface Culling is done in the shader so you would have to write your own shader to disable it in Unity. The better option is to make sure that all triangles are facing outwards as they should. To do that in Blender, select all faces and then do Mesh>Normals>Recalculate Outside.

If you want faces to be visible from both sides, you’d have to duplicate them and flip the normals on one copy.