Blender model to Unity quality low (polygons visible with texture)

I created a model within Blender which looks great while previewing with texture mode on. It also looks great when I export the DAE and use it in SceneKit (Xcode).

When imported into Unity, I can see the polygons even after applying the texture. I’ve made sure there is no texture compression, anti-aliasing is off, and I’ve tried some other methods on this forum.



Any ideas?

There are a few things that could cause this. The one that comes immediately to mind is that by default, Unity “optimizes meshes” which means that it clears vertices out of models that it thinks are unnecessary. In the import settings for the mesh, turn off Optimize Mesh, click apply and wait for the reimport to happen. It might resolve this. Another possibility is that there are actually border edges in blender at the points where those diamond shapes appear. In Maya, you can turn on a shader to highlight border edges so it’s obvious that there’s a hole technically where there shouldn’t be. I’m not sure if you can do the same in Blender. Yet another possibility could be that unity is trying to use quads where you’ve used triangles or vice versa. This is also an option in import settings: “Keep Quads.” Also, vertex welding might be happening. I’m not sure. I’m a programmer, but one of our modelers wanted me to learn a bit of Maya, so that’s what I’ve got.

It’s starting to look good now. I played with those settings more. A combination of enabling weld vertices and setting normals to calculate and the normals mode to unweighted did the trick.