Blender text

I have a text from blender and when i am look at the text i have lag.

Text image:
89349-9abf4a06505934277c2dc47313ff3d7c.png

It is because the detail is just too big. On the text settings, set the preview resolution from 2 to 4. Keep the number as low as possible. 3 seems to be good enough, but if you really need extra detail, 4 would be good.