Blender -> Unity animation issue

I’m not entirely sure if this is a problem with blender or unity (I’ll ask the same question on the blender forums as well, because I think it’s with it, but maybe someone here can help anyways)

Basically the problem is that my character animations are lower than the actual mesh. So I place the character mesh in the scene, with it’s collider (as part of characterController)
Then If I disable animations, everything works as needed. But with the animations enabled, once they start playing the location of the character moves a bit (I guess the animations aren’t lined up with the base mesh?) This is a problem because the collider doesn’t move with it. In blender though they all seem to line up. Does anyone know what’s wrong??

Make sure to apply the rotation, scale and location of you model in Blender before exporting it.

In Object mode: Object–>Apply–>Rotation/Location/Scale

I am happy I could help!