Blue scene screen with cardboard sdk

I am new to unity, making my first project.
I put “CardboardMain” as main camera but when trying to play the scene, it comes a blue screen only,
like that

I searched for any solution but to no avail

thanks in advance

You have to enable the skybox in:

CardboardMain → Head → Main Camera → Inspector: Camera → Clear Flags : Skybox

The scene you are showing on your screenshot is pretty empty except the cardboard camera setup and a directional light.

The blue you are seeing is the color with that unity will clear the screen with and will be the background.
If you had other stuff befor you might have the wrong scene opened.

I found that in the newer version of Google VR the answer is in Player > Main Camera

This is an old post, but one often occuring reason with Unity novices for getting a blue scene view when running your Unity app on the cardboard might be that you did not add the scene in the Build Settings. A mistake easily made.

I have resolved my issue for Google cardboard by these steps.

Edit -> Project settings -> Player -> Other settings -> Graphics APi

And remove Vulkan from the list by clicking - at the right bottom of the box.