Blurring a texture without blurring everything

Hey Guys, I have an app where I must blurr a texture, but not the whole screen. In my scene, I have 2 camera, 1 that displays all the textures that must not be blurry and one that displays the blurred texture. I have pro so I use the blur script from there but for whatever reason, it seems to affect the all the textures even though there on different layer than my blur camera renders, they have a different material too, I really don’t know why it is blurring the entire viewport and even though my textures are on another camera, there are still blurred. I figured out a way to fix that by using render texture , but it is kind of a pain to do, I have to size down my camera so it fits the texture and then I can project my camera to the texture and all other textures don’t get blurry. Am I doing it the right way or I’m maybe missing something that could do it easier. Here is a screenshot that shows my sprite on the left that must not be blurred and the one in the right that, I blurred using the trick above.

Thanks a lot for your time :slight_smile:


Make sure you’re using layers properly - you might be setting the camera gameobject’s layer rather than the camera’s culling mask layers. To specify the layers which each camera renders, use the “Culling Mask” dropdown menu on the camera’s inspector. This allows you to check or uncheck any combination of layers that the camera should render:


Found It. My problem was actually with the order in which the cameras were drawn. The main camera (no blur) was rendered first (order -1). After that, my camera was rendered (order 0). I tried to switch them up, I put my clear flag to don’t clear on my main camera, with a solid color on my blur camera, and it turns out that it worked just like I would expected. Only the texture that I wanted to be blurry was blurred. Hope it helps. Thanks a lot for your time :slight_smile: