blurry pixel edges

Despite setting things to Point, Truecolor, and turning off mipmaps, the edges of sprites are blurry when running the game.


Is there a way to fix this so it’s crisp or is this just Unity and 2D?

Have you tried different import settings for the image?

Some settings are geared for different purposes and so they may be nicer on 3D models, but not so nice on UI or sprites, and vice versa.

EDIT: I didn’t mean to sound like I ignored the first part of your post. I mean there might be a strange intermediate solution, like how before Unity 5, I could achieve sharp textures by using the Cursor texture type when importing. In Unity 5, there’s something for Sprites (2D and UI).

WOW im late for this answer…

I had the same issue.

DONT WORRY, there is a fix

If your having the same issue as me, you will have to go to the import settings > Sprite Editor
Then in the top left, there will be a drop down menu, from this menu select Edit Outline, then drag the corners and add more to match as close as possible the sprite itself, apply and see if that fixes it, if not
there may be something else, but its most likely this.