blurry screen/textures patch

This problem is still plaguing me after starting a new project. I’m almost convinced it’s a video card problem since I could not be helped with it previously.
I get blurry patches on my textures on my screen, and I believe they go completely across the screen. They also change with angle of camera and distance as shown below:

No Obvious Blur

Blur along bottom of totem after a tiny bit of distance

Blur after a bit of camera angle

please give me your suggestions. Thank you.

Enable Anisotropic Filtering in your project settings and texture import settings. This will favor more detailed mipmaps at steeper viewing angles, perceptually removing the blur.

In Unity’s Quality Settings, switch “Anisotropic Textures” to “Forced On”. Then, select your texture in the project window and raise its “Aniso Level” in the inspector until the texture looks less blurry. Note that you’ll need to apply the changes before they’ll be reflected in the scene.

Lastly, switch from Bilinear to Trilinear filtering in the texture import settings to prevent popping between mipmap levels.