Blurry Texture Help

I just got done making a simple watermark for my game in photoshop. Now when I import the image it becomes blurry when i set it as a gui texture. Is there a way I can not make it blurry?

  1. May be “format” parameter of texture is “Compressed”. Try “truecolor” or other.
  2. May be “texure type” parameter is “Texture”. Try “GUI”.

There are several things to take into account here:

Make sure you are using an uncompressed RGB(A) 32 (Truecolor) format for the image in it’s import settings.

You will also want to turn mipmaps off in advanced settings, or just select GUI which will do it automatically.

In some cases you might also want to change the bilinear filtering to point filtering instead.

Hope that helps.


It can also be a size issue. What is the size in pixel of your image ? What is the max size on the import settings ? How are you displaying it in Unity ?

there are several ways, although you should choose wisely based on the device you want to publish the game on.
1- what is the DPI resolution of the image you created? if it is 72 that usually it’s not enough. I assume you are using a PNG format right?
2- in unity, select the texture file you have (this watermark you have imported) and you can see in inspector that you have several option on how to import this into the engine. try to change the filter mode there and see how it works
3- in the inspector panel (as mentioned above) change the format setting to 16bit instead of compressed, in this case you can change the max size as well
I hope this helps, let me know if you need anymore help

I believe textures have to be powers of two pixels in size, if it is not already, try changing the size to 64x64 or 128x128 or whatever suits best. This can then be stretched or shrunk in the scene in any way you want.