Bone animation: unwanted objects with key frames

Hi guys,

I have a bone animation on a machine on 3DS Max. Only 2 parts are animated. I’m exporting my file as fbx to Unity, checking Bake Animation, but every time I try to import to Unity, my animation contains key frames in all parts of my machine, not only the parts animated. I’m using Animation component, and I need to use Animation Type: Legacy (Store in Root (New)).

I’m having frustrating behaviors with 2 animations on the same time. I tried to delete the unwanted frames on Unity, but they ever come back.

How can I avoid this?

Well, not sure what 2 parts you’re talking about, but checking the “bake animation” option applies keyframes to ALL objects in your file.

Cheers !