Break Prefab Instance does not work in Unity 5.3.2.f1

Hello, I’m trying to create 2 similar prefabs, let’s say a blue block and a red block.
I have created the red block, added some scrips and a shader with red color. Now I need a new block just like this one but blue. I have tried to pull the red block in the scene, change it’s color to blue and drag it back down in the project panel but by doing this the red block also changes to blue. I have tried the GameObject / Break Prefab Instance menu option but it does not seem to work. I’ve seen someone else complaining about this in 5.1
Does anybody else have this problem or is this menu option not supposed to do what I think it should do? :slight_smile:
Thank you

OK, I found the problem here: Breaking prefab connection - Questions & Answers - Unity Discussions and it’s not a bug it was just me not knowing how to Unity :slight_smile:
As whydoidoit said: “You are changing the colour property of a material this is a separate object to your prefab. You need to make a new material for every level or create some script that will assign it at run time.”
After I created a new material for each block it worked.