BSOD on building EXE and APK i9 14900k RTX4070

Hello,

Using 2022.3.21f1 LTS I am able to create EXE and APK on my Omen laptop i7 9th gen RTX2060 16Gb ram DDR 4. Everything works without any problems.

But I am unable to build EXE or APK on my PC
i9 14900k
Gigabyte RTX4070
Corsair 64Gb DDR5 6200Hz (4 sticks)
GIGABYTE Z790 GAMING X AX
Seasonic Focus GX, 80+ Gold, 750W - FOCUS-GX-750

At work we are working on a SDK for over two years and now that I switched to this new pc I can't build EXE or APK.
The SDK contains dlls, custom shaders(vertex, surface). The custom shaders present no problem on my laptop but on the pc it seems that the shader compilation fails and gives a BSOD with the code clock watchdog timeout. After I remove the shaders the EXE works but the APK fails. It gives a lot of BSODs when trying to switch to Android platform or to set it on Linear rendering.

The APK build settings are

What I tried:
Took out the GPU
used a single RAM stick, used single channel (3rd and 4th slot)
lowered max CPU in windows settings to 99%
the CPU does not have an overclock
the memories do not have any boost, no XMP
Bios is updated F9
Windows is new and last update was yesterday
2024-02 Cumulative Update for .NET Framework 3.5 and 4.8.1 for Windows 11, version 23H2 for x64 (KB5034467)
Performance testing programs work without problems
Games work without problems
Unity version was installed with it's Android SDK from unity HUB
Unity hub version: 3.7.0

(PC/Windows Build) I need to remove the custom shaders in order to build or else I get a BSOD clock watchdog timeout. But does this mean I can never add shaders to the project? I do not think this is a solution.

(Android Build) Never works. When I remove the shaders sometimes it manages to compile then but I get 20 errors similar to:
Building Library\Bee\artifacts\Android\87lik\sxq1da639g3f.o failed with output:
Also
c++ clang

I tried to add new Android Studio SDK manually but it did not accept it.

All this work and changes just to avoid BSOD on this new PC while the Omen laptop works directly wihout problems.

I saw a lot of post complaining about i9 processors or RTX4xxx GPUs, but considering I removed the GPU and it still failed, I am not sure about it.

Does anyone encounter these problems? Is it an incompatibility issue between my i9 and unity? is the CPU too new for Unity development? Can the RAM be too high frequency?

The APK build settings are:
Minimum API Android 10, level 29
Maximum APIAndroid 13, level 33
Scripting backend IL2CPP
ARM64

This apk will be put on Oculus quest 3
Will also have XR Plug-in management with Oculus


Just a hunch but this PSU seems slightly underpowered for this rig. If you use a PSU calculator they'll probably recommend 900W+ but of course, the calculators usually want to sell bigger PSUs. And with no overclocking it should be fine, but it can't hurt to take the sums of the max W load of everything you have installed.

Careful with the "overclocking" statement on the 14900. Out of the box it is a 13900 overclocked, because Intel got the BIOS/Board manufacturers to set the power limits to default to the values that the 13900 only used when overclocked. It may help to check which setting(s) forces the CPU to stay within the 13900 power limits.

BSOD is pretty indicative of a hardware or driver issue. You should try the Nvidia Studio driver (not: Game Ready) because they are touted as more stable and compatible.
Since the system is new, check device manager. Are there any yellow exclamation marks? If so you may not have installed all necessary drivers, specifically the Intel chipset drivers are very important.

If nothing seems to help try running an actual burn-in test that puts the heaviest load on your machine: Furmark + Prime95 (with the "hot" option ie run within CPU cache) and let that run for at least an hour or two. If that runs fine, then also an overnight RAM test with memtestx86 to verify there's not the least bit flipping (literally).

2 Likes

Thank you for the clues! I managed to solve it.

Indeed i9 14900k is always overclocked in the motherboard's default settings and it was a very unstable overclock. I had to disable all settings that were responsible for the automatic overclock. The most important one was Intel turbo booster that was creating the problems. I had to set the lowest C state to C1.
You can put the name of your processor in google, for example " i9 14900k" and there you can see the modes in which the processor will run. That is related to "Performance CPU Clock Ratio". I had to lower it to 56 which means 5.6Ghz and that puts it in the mode "Performance-core Max Turbo Frequency " which disables some overclock technologies from the processor

9714517--1388413--20240321_135227.jpg
9714517--1388416--20240321_135304.jpg
9714517--1388419--20240321_135319.jpg
9714517--1388425--Screenshot 2024-03-21 140449.png

1 Like

The C state limit is actually powersaving technologies. If you don't let the CPU fall down to 7 or higher the CPU runs at full power draw most of the time, unnecessarily heating up and consuming energy. Remove or raise the package limit and enable C states up to C10. This should not affect stability (unless under extreme overclocking).

If the default overclocking failed then perhaps cooling is an issue. It's widely agreed that the 14900K should not be air cooled since it will very quickly throttle.

1 Like

Thank you! I have a similar setup to yours and was getting frustrated trying to find a solution. I was also attempting to verify the integrity of the hardware since I encountered some BSODs when compiling to WebGL. However, no stress testing software indicated a hardware issue.

But simply disabling Intel Turbo Boost in the BIOS was enough to finally allow compilation to complete successfully. I'm not entirely sure why, though...

High temps that later turned into BSOD/strange performance issues/crashed in editor etc. are related to incorrect default mobo settings for all brands "MSI/ASUS/GIGABYTE etc... follow this video it will sort out the temps and give you the correct settings for the i9's. Hope it helps anyone reading this, it did for me, my build is finally stable:
https://www.youtube.com/watch?v=tcjkNSySzsg