Bug in Animator layer blending ?

Hello Unity devs !

Here’s the case : I have 2 layer in my animator : One for the walk/running animation (Layer 1), that animate all the body, the second one for only the hands (Layer 2, override mode).

So if the override blending in Unity works as intended : If the transform is not controled in Layer 2, Layer 1 takes the control. I understand that.

To sum up the case :

  • Layer 1 animated constantly both right and left hand

Layer 2 :

  • Empty state : No animation

  • Equiped state : Animation only on the right hand

  • Aim state : Animation on both hand

Transition between Empty and Equiped => Okay, the left hand just keep its position/rotation define in the current running Layer 1 animation. Works well in both ways.

Transition between Empty and Aim state => Okay, the left hand blend well between its Layer 1 animation and the Layer 2 “Aim” animation. Works well in both ways.

Transition between Equiped and Aim state => Failed. The left hand is blending with its “default” position, and then clip instantly with it’s Layer 1 animation when the transition is over. This is very weird.

Question : Is this a bug or it is intended ? How can I blend the left hand correctly in the third case ? Do I miss something in the understand of blending with 2 Animator Layer ?

Thanks a lot !

I had the same problem, sadly the only solution I found was decreasing and increasing the weight to fake the blend, it works, but it’s an innecesary time consumption, hope they solve it in next versions :S

(Tried in unity 2018.2.6f1)

Still havent solved this for version 2021.1.16f1… Thanks Unity :\

So I started working on the animation for my stage fright website and I’m facing the same issue. Would be helpful if it would be solved.

I have a very similar issue in my game. Similar setup – my base layer is for full-body movements, and then I have one more layer with an avatar mask for the upper body. I use this layer to move the arms and torso when shooting a bow.
When each transition starts in the override layer, there is a strange animation stutter, as if the animation weight of the second layer was being popped back down to 0 at the start of each transition. I’ll probably post this as a separate question with a video. Hopefully it’s something dumb that I did, rather than an issue with Unity.