[BUG] Issue in Unity 5.5.1 when using Ads from Services window (use asset package)

As the title says - we've noticed some issues with the Services window -integration for Unity Ads.

This only applies to projects using Ads from the services window - projects that have the Asset Store integration for Unity Ads are safe.

Avoid updating to Unity 5.5.1 if you're integrating Ads from services - or use the Asset Store package.

More information will follow under this thread.

Edit: issue was fixed, update your editor: https://forum.unity3d.com/threads/bug-dont-upgrade-to-unity-5-5-1-if-using-ads-from-services-window.453084/#post-2967990

This is also fixed in 5.5.2

I have a question regarding the built in ads. Are the patches using the latest version?
Or if one wants to use the latest version, should use the asset one?

If you are using the latest version of Unity (5.5.1), we recommend using the asset package integration.

https://www.assetstore.unity3d.com/en/#!/content/66123

I always am, i just want to see if there is a plus for using the built-in one.

Thank you for the info
I've been learning ads yesterday with 5.5.1
I'll try to asset store SDK today

PS. Please remember to update the info on the asset store because it
guides you to use the services ads if you are on new versions of Unity

Just a quick update, the issue has been fixed and verified in Unity 5.5.1p2, which should ship soon.

Some additional information on this issue. The issue appears when building and deploying an .ipa file to the iOS device, just running from Xcode doesn't trigger the issue. And since our testing, including automation, would just run from Xcode or similar command line task, we didn't catch this issue during our internal testing for new Unity versions. And was caused by a change to code stripping in Unity, which affected the Ads SDK. We will ofc cover this scenario in testing from now on :)

/Rasmus

Thanks for the update.

"Build and Run" to test burnt us too. It wasn't until someone tried the live version on the store that we noticed the ads weren't working. :(

I test sporadically via TestFlight now just to make certain everything works, now that I know this is possible!

So it's safe to use 5.5.1f1 with the services window integration for Unity Ads if I just want to export apk file right ?

@T2GGames This issue only affects iOS. You are safe to build to Android.

I am using this script to show real time ads in my app , I added this script to my gameobject
and enable ads test mode than every thing working fine ... but when I disable ads test mode from my service window in doesn't show ads . I am building for android .

using UnityEngine;
using System.Collections;
using UnityEngine.Advertisements; // Using the Unity Ads namespace.

public class ShowAdOnStart : MonoBehaviour
{

if !UNITY_ADS // If the Ads service is not enabled...

public string gameId; // Set this value from the inspector.
public bool enableTestMode = true;

endif

IEnumerator Start ()
{

if !UNITY_ADS // If the Ads service is not enabled...

if (Advertisement.isSupported) { // If runtime platform is supported...
Advertisement.Initialize(gameId, enableTestMode); // ...initialize.
}

endif

// Wait until Unity Ads is initialized,
// and the default ad placement is ready.
while (!Advertisement.isInitialized || !Advertisement.IsReady()) {
yield return new WaitForSeconds(0.5f);
}

// Show the default ad placement.
Advertisement.Show();
}
}

1 Like

Just checking that this issue should be resolved for 5.5.1p4?

@ina , correct was fixed in 5.5.1p2. You can find it under release notes for that version on https://unity3d.com/unity/qa/patch-releases?version=5.5

/Rasmus

1 Like

How can this just be a bug post in the forums? I just discovered the effects of the bug today when integrating Ads into my new App and it turns out it's been around for some time.
I had a look at one of the games that I updated 20 days ago and true enough, Ads are NOT working in the Game.
So you have a Bug that stops ALL Ad monetization for an entire platform and you don't even warn the developers about it? Who even checks this forum on a regular basis? I've never even been in this subforum before...
Also.. Cloud Build is still using the bugged version for builds so even if I build it today with "Always Use Latest 5.x" it will still build it with the bugged version and Ads will NOT work. This is a fucking disaster. My confidence in Unity just took a big hit...

2 Likes

I agree that there should be a global notice to all Unity ads users - or a system for notifying affected users of mission critical bugs. The forums are disorganized and you can't find the post that is relevant to your issue unless you actually use a third party search engine to find it (and even then sometimes the links are outdated). Unity Answers is, unfortunately, quite borked as well. These tools are not hard to fix for any standard full stack developer, but I suppose they aren't considered core product, so no one cares to fix it.

In balance, supposedly Unity makes so much from Unity ads that it funds the entire company to the point where they don't even need to charge for the actual IDE... but they still charge it since people are willing to pay for a game engine. Maybe they noticed a dip in $$$$$ when people re-building their game with the last few sub-versions of Unity could not get ads to monetize.

1 Like

This is extremely confusing, this bug breaks every single IOS services advertisement integration and there's nothing more than a forum post to explain it.

It takes ~2 weeks to have an app approved into the app store, so even at best case scenario you're stripping developers (and yourselves..) from ad revenue for easily 14 days without proper communication about this issue. Why is there no message within the unity ads dashboard?

Very lucky I saw this thread, else I'd have some EXTREMELY pissed off people to deal with

2 Likes

Hi there, im using same apps that i created before using 5.4.1 and run at the latest version, please read "latest version". In the latest version unityadseditor doesn't initialize in console window even this log doesn't show in console window. But if i open it using 5.4.1 in the console window will say unityads initialize with blablaba ID, true.
The bad news is my apps already opened in the latest version but now it crashed open in the old version, test with 5.4.1 and 5.4.4. Totally crash. How do i fix this?

For more information, i build using ios build, unityads integrated. Import from package that create from latest version before into 5.4.1 or 5.4.4 also crash when run.

Yes, 5.5.2

Latest version = Unity 5.5.2?

It is not guaranteed that a downgrade in editors will always work with projects.
When you say "Import from package" do you mean the Unity Ads package from the asset store?
You can't have the built in ads enabled and then import the asset store as well.


I think im not disable the build in ads when export package. Thats why it crash when i import and run in older version. Do i have anoyher option to make it work at low version again? Since the original file project already crash when i opened it using low version. This unityads problem is real pain, always have a new problem in every new version, this is ridiculous

forget it, i already make it work again but my question is not yet answer. im using 5.5.1p4 now, but when i run, theres no "UnityAdsEditor: Initialize(MYIDNUMBER, True); UnityEditor.Advertisements.UnityAdsEditor.EditorOnLoad()" log in console but it showed in old version unity 5.4.1 before. I already tried such as, turn on/off Enable builtin Ads extension, turn off the builtin ads extension and import unity ads package but it still same.

Is this problem still in 5.5.1f1?
Because I'm trying to get a simple showAdOnStart script to work and I even used the code samples, I attached the script to the main camera but it never shows the ad when I run it. Its like it gets stuck on the isReady function. But, I have internet connection so I dont understand. The same code worked for me a week ago but now it doesnt.