Build error, unityStreamingAssets gardle.

Hi, i cant build the game.
First i got this error at exporting:
mainTemplate.gradle file is using the old aaptOptions noCompress property definition which does not include types defined by unityStreamingAssets constant.

I solved this issue by changing in the mainTemplate.gradle file from this:

aaptOptions {
noCompress = [‘.unity3d’, ‘.ress’, ‘.resource’, '.obb’STREAMING_ASSETS]

to this:
aaptOptions {
noCompress = [‘.ress’, ‘.resource’, ‘.obb’] + unityStreamingAssets.tokenize(', ')
ignoreAssetsPattern = “!.svn:!.git:!.ds_store:!.scc:.:!CVS:!thumbs.db:!picasa.ini:!*~”

The problem gone but i got other errors end of my build.

First Error:

Configure project :launcher
WARNING: The option ‘android.enableR8’ is deprecated and should not be used anymore.
It will be removed in a future version of the Android Gradle plugin, and will no longer allow you to disable R8.

Second Error:
FAILURE: Build failed with an exception.

  • Where:
    Build file ‘C:\Users\user\Documents\MyGame\Temp\gradleOut\launcher\build.gradle’ line: 30

  • What went wrong:
    A problem occurred evaluating project ‘:launcher’.

Could not get unknown property ‘unityStreamingAssets’ for object of type

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

Cant rid of these error .

I use Unity 2020.2.4f1 .
Have you ever faced with this issue? Can you help me?

Solved! I just simply downgraded to unity 2019.4 and the error gone.

You can change your aaptOptions as
noCompress = [‘.ress’, ‘.resource’, ‘.obb’, ‘.bundle’] + unityStreamingAssets.tokenize(', ')
ignoreAssetsPattern = “!.svn:!.git:!.ds_store:!.scc:.:!CVS:!thumbs.db:!picasa.ini:!*~”

and add to gradle properties ( click it on the player settings if its not on)
then add to the end of file after ADDITIONAL_PROPERTIES
unityStreamingAssets=.unity3dSTREAMING_ASSETS, google-services-desktop.json, google-services.json, GoogleService-Info.plist