Build for Android only has max target API 28?

I’m building an android app. Previously, I had minimum version 8.0 (API level 26 or so) and target platform highest installed. This works fine on my device when I attach it via cable, but now that I want to upload the app to the play store, it doesn’t work anymore.

The play store apparently requires a minimum API level of 29. However, this option doesn’t appear within my player settings drop down. It goes up and until 28 and also has an option “Highest installed”. I use the SDK tools via Unity hub so I don’t know if I can update those.

I’m running Unity 2019.1.7f1 and I really don’t want to upgrade this, since I’m also dependend on a ton of other packages and colleagues who run this version. Any method with which I can build for the SDK platform level 29? I can’t imagine this isn’t possible with my current setup and I’m working towards a deadline. Let’s hope it’s an easy fix…

Yes one way is to download Android SDK manager and download the API you want and then go to

unity → preferences and manually
select the SDK folder where you
downloaded the latest one right now.

Easy way to download SDK is following this video https://www.youtube.com/watch?v=isXLx7HcpFA&list=LLT1BhgdpO0DvXlauzS4rFPA

Or you can download android studio and then use it’s SDK manager

Or you can use CMD for it too.

I hope this helps!