Build/play freezes editor (2017)

I imported my project with Unity 2017.1.0f3 and I am completely unable to run the game.
If I press the play button in the editor, it freezes (Not responding), same when building to an Android device: editor freezes at compiling the first scene.

Thanks for replies! It doesn’t happen in an empty project. Same project builds and works with Unity 5.6.1.
Unity log file

LICENSE SYSTEM [201788 13:38:3] No start/stop license dates set

LICENSE SYSTEM [201788 13:38:3] Next license update check is after 2017-08-09T09:12:10

Built from ‘2017.1/release’ branch; Version is ‘2017.1.0f3 (472613c02cf7) revision 4662803’; Using compiler version ‘160040219’
OS: ‘Windows 10 (10.0.0) 64bit’ Language: ‘en’ Physical Memory: 8075 MB
BatchMode: 0, IsHumanControllingUs: 1, StartBugReporterOnCrash: 1, Is64bit: 1, IsPro: 0

COMMAND LINE ARGUMENTS:
D:\work\Unity2017\Editor\Unity.exe
[CEF] undefined in file:///C%3A%2FUsers%2Fzak%2FAppData%2FRoaming%2FUnity%2FPackages%2Fnode_modules%2Funity-editor-home%2Fdist/assets/unity-editor-home.js at line 39
Error loading launcher://unity/C:/Users/zak/AppData/Roaming/Unity/Packages/node_modules/unity-editor-home/dist/index.html?code=jg1gv3rl0wG6cdttuokomQ006f&locale=en&session_state=0dc5c8b175b2eb0e58356e4fe615e3b5452e1f544be4e6635a75ab7894c75077.fWX7dn1v3MclXsX2tamP0Q006f#/login

(Filename: C:\buildslave\unity\build\Editor/Platform/Interface/NativeWebViewWindow.cpp Line: 51)

[CEF] undefined in file:///C:/Users/zak/AppData/Roaming/Unity/Packages/node_modules/unity-editor-home/dist/assets/unity-editor-home.js at line 39

Does that still happen with an empty project?

If not, you’ve probably got an infinite loop in your code.

Getting similar issue, on Unity3D 2017.2, Win 10 64bit
targeting android

A) open a new Project, which is fine. some of other small project also okay.
B) one of the project will freeze when click play, even it’s a new empty scene.
the same project were running fine in Unity 5 ~ 5.6

Tried actions

  1. updated Android NDK from 10e to r13
  2. the best answer of this post

getting following log after I clicked play button.
it just hang at the end of the line ( for a new scene without anything but the default camera * light)
"Load scene ‘Temp/__Backupscenes/0.backup’ time: 0.287734 ms "

reference

----- Total AssetImport time: 0.385837s, AssetImport time: 0.000000s, Asset hashing: 0.000000s [0 B, 0.000000 mb/s]

  • Completed reload, in 2.425 seconds
    Initializing Unity.PackageManager (PackageManager) v2017.2.0 for Unity v2017.2.0f3
    Registering platform support modules:
    Registered platform support modules in: 0.0352079s.
    Native extension for WindowsStandalone target not found
    Native extension for WebGL target not found
    Native extension for Android target not found
    Refresh: detecting if any assets need to be imported or removed … Refresh: elapses 0.429020 seconds (Nothing changed)
    Refresh: detecting if any assets need to be imported or removed … Refresh: elapses 0.379666 seconds (Nothing changed)
    Initialized touch support.

D3Dwindow 1eb06690 Reshape 32x32 d=0
D3Dwindow 1eb06690 Reshape 500x400 d=0
Refresh: detecting if any assets need to be imported or removed … Refresh: elapses 0.391594 seconds (Nothing changed)
Refresh: detecting if any assets need to be imported or removed … Refresh: elapses 0.380890 seconds (Nothing changed)
Refresh: detecting if any assets need to be imported or removed … Refresh: elapses 0.379892 seconds (Nothing changed)
Refresh: detecting if any assets need to be imported or removed … Refresh: elapses 0.377091 seconds (Nothing changed)
Refresh: detecting if any assets need to be imported or removed … Refresh: elapses 0.405096 seconds (Nothing changed)
D3Dwindow 1eb031f0 Reshape 1239x664 d=2

Packing sprites:
[ 132 MB ]- Collect Sprites to Pack : (SequentialAtlasing : 0)
[ 132 MB ]- Grouping sprites using the selected SpritePackerPolicy.
[ 234 MB ]- Atlas “ui_Common” with 57 sprites assigned.
[ 234 MB ]- Atlas “ui_Currency” with 23 sprites assigned.
[ 234 MB ]- Atlas “ui_Hero” with 24 sprites assigned.
[ 234 MB ]- Atlas “ui_InGameHUD” with 6 sprites assigned.
[ 234 MB ]- Atlas “ui_Rune” with 43 sprites assigned.
[ 234 MB ][ 234 MB ]- Completed grouping sprites to Atlas.
[ 234 MB ]- Build Sprite Atlas.
[ 235 MB ]- Packing 5 atlases.
[ 235 MB ]WARNING: ASTC texture format is not supported, decompressing texture

  • Atlas (ui_Common) file (4eb82cfdcc019964580010163af7117c) found. Mapping.
    [ 240 MB ]- Atlas (ui_Currency) file (eb72aed7a460126fc2328270abea4db8) found. Mapping.
    [ 255 MB ]- Atlas (ui_Hero) file (b5f845e0b3058b299e91a1eda2628ce8) found. Mapping.
    [ 255 MB ]WARNING: ASTC texture format is not supported, decompressing texture
  • Atlas (ui_InGameHUD) file (09ab53758a39b16cd57f1f7fba440f33) found. Mapping.
    [ 250 MB ]WARNING: ASTC texture format is not supported, decompressing texture
    WARNING: ASTC texture format is not supported, decompressing texture
    WARNING: ASTC texture format is not supported, decompressing texture
  • Atlas (ui_Rune) file (327a1175196936771379650913d60e36) found. Mapping.
    [ 247 MB ]- Packing completed.
    [ 254 MB ]- Update Sprites and Cleanup.
    [ 254 MB ]Reloading assemblies for play mode.
    Begin MonoManager ReloadAssembly
    Refreshing native plugins compatible for Editor in 2.89 ms, found 6 plugins.
    Preloading 2 native plugins for Editor in 0.10 ms.
    UnityIAP: [InitializeOnLoad] Facebook Check
    UnityIAP: Runtime [2017.2.0f3]
    UnityIAP: Current Build is Android:Android
    UnityIAP: stub Facebook.dll enabled
    Mono: successfully reloaded assembly
  • Completed reload, in 2.236 seconds
    Initializing Unity.PackageManager (PackageManager) v2017.2.0 for Unity v2017.2.0f3
    Registering platform support modules:
    Registered platform support modules in: 0.0367527s.
    Native extension for WindowsStandalone target not found
    Native extension for WebGL target not found
    Native extension for Android target not found
    Load scene ‘Temp/__Backupscenes/0.backup’ time: 0.287734 ms

… Freezing the editor after just-selecting some game objects (and clicking on their script values in editor) is still present issue (Unity 2017 4.40f1, WIn 10). This version of Unity is btw known as best-forever Unity version and it was most stable and we know it as very reliable, to this day. Has anyone identified perhaps Microsoft updates issue in the conneciton with this, or what should we do, as we hear that this same issue is now present also in the 2020+ verisons, to-day ? Thanks.