Building for iOS - Undefined symbols for architecture armv7

looks like I am not the first, who is asking about this issue but I need to try. Does anybody encountered this problem?

Undefined symbols for architecture armv7:
  "_OBJC_CLASS_$_GSDK_GTMSessionFetcher", referenced from:
      objc-class-ref in gpg(GPGClearcutLogger.o)
  "_OBJC_CLASS_$_GSDK_GTMSessionFetcherService", referenced from:
      objc-class-ref in gpg(GIPNetworkImage.o)
  "_GTMMethodCheckMethodChecker", referenced from:
      +[NSDictionary(GTMNSDictionaryURLArgumentsAdditions) xxGTMMethodCheckMethodNSString32] in libGoogleToolboxForMac.a(GTMNSDictionary+URLArguments.o)
      +[NSDictionary(GTMNSDictionaryURLArgumentsAdditions) xxGTMMethodCheckMethodNSString33] in libGoogleToolboxForMac.a(GTMNSDictionary+URLArguments.o)
ld: symbol(s) not found for architecture armv7
clang: error: linker command failed with exit code 1 (use -v to see invocation)

It looks like, some Google Play dependency is causing it, if I got it right. I already tried playing with scripting backend, architecture and target minimum iOS version in unity - no changes
Then I also tried to switch some values in XCODE recommended in other threads with similar issue. Namely build settings → architectures, valid architectures, supported platforms, base sdk, active architecture only. Also no changes, still the same error during linking.

I use XCODe 8.1, unity 5.3.6f1.

Any suggestions?

I managed to solve it by myself. The key is to edit the pod file like this (tested with the unity 5.3.6f1, GPG games plugin 0.9.34 and xcode 8.1):

platform :ios, '8.0'

target 'Unity-iPhone' do
pod 'GooglePlayGames', '5.1'

then you need to run pod install and it works!