Building for iOS, Unity 5 - without Developer Account

Hi there,

I came across this piece of information:

What I gathered from there (and elsewhere) is that I now should be able to build and run Unity project on my iPad? I understand that features are limited compared to Developer Account features.

Despite the fact that I’ve never built anything on iOS device I went ahead and tried to do so. But no luck, after all steps I end up with error:

clang: linker command failed with exit code 1

…and a ton of paths and text above it.


What I did:

(I did check Unity “official” video - YouTube)

  • Installed OS X Unity 5.1.2f1 (not a
    patch version)

  • Downloaded and installed Xcode 7 beta
    5

  • Created new empty project, added a
    cube

In Unity:

  • Build settings, selected iOS, changed
    to that

  • Opened Player settings, set bundle
    identifier to something unique

  • Made a build, unity says “Build OK”
    or something like that (so Unity part
    went OK?)

In Xcode:

  • Open project
  • In General / Identity / Team I
    selected my “account” which is type
    “Free”
  • In Build Settings / Code Signing I
    chose iOS Distribution (told me I
    don’t have it, OK) and chose iPhone
    Developer:myE-mailHere
  • Performed Product menu / Clean

Then when I try archive / or build, I get the error (like I mnetioned already…):
“clang: linker command failed with exit code 1”


I’m total newbie with Xcode, and building to iOS also, so forgive me if I missed something obvious.

I did read Unity manual chapters and tried googling but didn’t find anything matching.

A. Should this advertised building for testing on local iOS work already?

B. Do I have the correct tools? I.e. Unity 5.1.2f1 and Xcode 7b5 ?

C. What did I miss? I basically have tried altering Unity / Player settings for:
iOS target version, Debug/release version, but same result.

any help and suggestions appreciated and thanks in advance!

This answer is bit late (Things might have changed as this was done in Unity 5.1.x and XCode 7 beta)

I solved the issue and solution was to disable “bitcode” in XCode project settings.