Builds won't run at all

For some reason I can’t get any of my builds to run regardless of platform. The game runs fine within the editor. When I do a Web Player build it produces a page that says " Unity Web Player | My Game Title " at the top, and “created with unity” at the very bottom in small text, but otherwise a blank white page. When I try to run a standalone build, it appears to try launching and then close down almost instantly after, like a flash on the screen. I’m worried it might have to do with renaming the project or moving files around outside the editor, which I did in the past. All the same, after I did that there was no indication of a problem anywhere else, and I have since then tried creating a new project and transferring all my content to it. Still no luck. I’m trying to put together a demo for someone tonight, and unfortunately I haven’t needed to do a build for a number of weeks, so it’s hard to tell how long the cause of the problem has been lurking around. Any help is greatly appreciated, and I’m sorry if this is vague. I’m happy to clarify if there are any questions.

Try a PC standalone build and see if it makes a log file anywhere. I wouldn’t expect it to be caused by moving assets outside the editor, if it was that, it wouldn’t work in the editor either.

If you can’t figure anything out from the log file, make a backup of your whole project and start taking it apart bit by bit until it works. Start with removing scripts since that’s what its most likely to be.

In my Unity 4.6.1f1 i have similar problem, i cant build on my Android device, application starts with a “black screen”. This is a problem with Unity versions, please update to patch version.

Unity Path Version

Alright, so this is really strange (or I’m really ignorant), but I actually solved my own problem. I figured out that when I include a ‘/’ in the file name (I was adding the date to each build, so 1/14/15) it keeps the file from loading in the way I described. When I use alphanumeric characters it works fine, and I was even able to get old malfunctioning builds to work by renaming them. Even other characters work fine. I changed the name to include every other non-alphanumeric character and it will run, but as soon as I include a ‘/’, it stops loading. Is this something I should have been aware of as a Mac user, or in general? If not can someone else check to see if adding a ‘/’ to their build name prevents it from running?