Built Unity game wont launch.

So lately, i have starting to have problem with Built game.
When i build my game, it builds without any errors / problems, but when i try to launch it, nothing is happening and i can only see “Loading” spinning in my cursor. I cannot even delete the file, because the PC tells the file is open in System, and only lets me delete it after i restart my PC. I cannot even see anything relatively close pointing to the game in my Task Manager, thus cant shut it down from there.

Also, theres is no critical errors to be seen in Console in any scene of the game.
Im using Unity 5.2.2f1 Personal, and Windows 10 64Bit.

Ive tried to mess around in Player settings, delete uselles files / prefabs, pretty much tried everything i can. The game runs perfectly fine in Editor, and builds it perfectly well. Yet it wont start. Not even with Administator rights.

I have no idea when this started to happen, but when it did, i havent been able to make any working build after.

So i fixed the problem. Now the Built game started immediatly.

  • I Unticked “Display Resolution

And after, built the game two times to make sure it was the problem. And it was.

I haven’t switched to win10 since it seems to have quite a few issues (not just with Unity). However as far as i can tell the taskmanager looks the same as in win8.1. Just forget about the “Processes” tab. It’s quite useless and messy. It only shows applications which have an active window open. Check the “Details” tab. There you will find all actual processes listed by the exe file name.

The Unity player creates a logfile (output_log.txt) inside the “XXX_Data” folder of your build, so check the log if it has any useful information.

Without more information we can’t tell you more about your issue since we can’t reproduce the problem.