Camera is culling terrain detail objects regardless of settings

I have a terrain, a camera and detail objects on the terrain. Regardless of camera culling or detail distance settings the detail objects are being culled a very short distance from the camera. Any suggestions would be greatly appreciated.

Thanks, Daniel

Right, so this could actually class as a bug! My solution, via much stress and detecting has been that having two of the same grass texture type, albeit with different size/colour settings, causes Unity to abandon the detail object settings entirely and perform a weird cull all of its own. I managed to repeat the bug twice in a new scene file. Incidentally, it was the grass texture that comes with the terrain assets pack that did it.

The solution itself was to delete both instances of the texture in the terrain, and add just one. I'm thinking that a copy of the asset would probably allow for a second version, but I haven't tried it.

If anyone can confirm any of this I might shoot the unity guys a message and report it as a problem.

Cheers, Daniel

This is a temporary solution, but all I could do is go to terrain settings and turn down the pixel error (1 for me) so that it shows clearly from a distance.

Had this problem as well. I deleted half my grass textures (20 down to 10) and it started working. Might be a limit to the number of individual grass textures it can use.

By the way:

The official unity car tutorial (car race) has that problem, too: Detail objects do not show unless run in editor. As soon as you build and run, the details are gone.

Would be cool if unity staff could take care about it.


By the way:

As far as I can see the official Unity “car race tutorial” has the same problem or bug. too: Detail objects are not shown, unless run in editor mode. As soon as you build and run it, details are gone.

Especially for a tutorial that should be corrected.

Would be cool if Unity experts could take care about it.


I am just now seeing this issue in my own project. My Detail objects do not have that many textures used in the scene, so I’m uncertain of a workaround. Anyone have any further suggestions?

Please tell me you’ve all submitted bug reports!