camera/minimap problem on upgrading to unity 5.4.2

I have a simple minimap setup using two cameras, with the main camera (depth -1) overlaid by a ‘minimap camera’ (depth 0) directed at a sprite, whose texture is updated via a script at runtime via spriterenderer.texture.setpixel().

This worked fine for in version 4.7 - the problem is I am finally getting round to upgrading unity from version 4.7 to 5.4.2f and have got everything working fine except the minimap, which is simply not appearing, even though the camera is active with the right screen coordinates, and the texture is being updated with no errors or warnings.

I am stumped as to what could be causing this, I wonder if someone with more experience of the differences between unity 4 and unity 5 will have an idea?

EDIT: I have just confirmed that I get the same problem with Unity 5.0.3f2, 5.2.1f and 5.3.6f1. I have tried changing pretty much all the camera and sprite settings with no luck, but I feel like there could be a very simple fix I am not thinking of.

OK, so I actually just managed to solve the problem by a process of trial and error. What I had to do was:
a) change the minimap camera ‘clear flags’ setting from ‘don’t clear’ to ‘depth only’.
b) change the import settings of my sprite to ‘mesh type: full rect’

I gather from the documentation that it is rarely correct to use ‘don’t clear’ so I guess this was sort of a loophole in version 4.7 that ‘don’t clear’ had the same effect as ‘depth only’.

I think the key one is (b) - since Unity 4.7 does not include the ‘mesh type’ import setting, it must have been set to a default option when upgrading, which turned out to be inappropriate ( I still don’t really understand what this import setting does, in case anyone would care to add something here).