Camera shows black screen on iOS Device

Hi,

I am using the Mars Facemask with Objects placed on the mask... Everything works fine in the Editor Mode... but as soon as I bring the app onto the device, the part where the camera should face to my face and show my face with the object on - this area is completely black!! Also the object cannot be seen... although it is there... and also the device asks for camera use permission with first launch...

Please help! I have tried all that I have found in the net? Anything else I can do?

I am using the following systems:

Unity 2020.3.25f1
Mars 1.4.1
AR Foundation 4.1.7
ARKit Face Tracking 4.1.7
ARKit XR Plugin 4.1.7
XR Plugin Management 4.0.1
URP 10.7.0

Following points have all been checked:

  • URP Forward Renderer
  • AR Background Renderer Feature is added to your SRP configuration
  • Default Island set
  • Enable the UseFallbackCompositeRendering checkbox in the CompositeRenderModuleOptions
  • AR Kit checked in XR Management
  • FaceTracking checked in AR Kit etc.

Is the whole screen black or just the face?

If you are willing to share your project with us you can use the Help > Report a Bug menu

not the whole screen. Canvas is visible… and if I switch the cam to a non ar cam it also works… everything in the view field of mars face cam is black…

FYI - Just reported the bug
Case 1393541

Thanks - yup, that is broken :( For some reason it's failing to initialize ARKit.

Can you try updating the AR Foundation packages to 4.2.2 (That's AR Foundation, ARKit and ARKit Face Tracking)? Those worked for me.

Of course this should work as 4.1.7 are the verified packages for 2020.3, so I'm going to dig into it a bit further.

i have updated to 4.2.2 and then downgraded again to 4.1.7 - it works!! Great!! Thanks a lot for the support!!