Can't Get Character From Maya To Animate

I’m new-ish to Unity, not Maya. Using Maya 2013 and Unity 4.
I’ve got my character setup in Maya fairly well, I’m pretty sure. Simple Bi-Ped. Did the skeleton, controls, IK myself. Anyway, I baked the animation, deleted the controls and then exported as FBX. I’ve brought the character into Unity, and can see it animating in the preview window. The animation works as intended. My problem shows up when I try to get it to actually animate in the game itself. All I get is the very last frame of animation, that’s it. I have a couple of scripts that are calling the animation, like when triggered by colliding with a box, etc. I have also tried just dumping the character in the scene, loading the animation in a Animation component and setting it to Play Automatically. Nothing, except the very last frame. Any suggestions?

Ok so I figured it out. Had to set Animation type to Legacy and Generation to Store in Root (New) on the Rig tab in Unity. Works now.