Can not destroy Transform component. after upgrade to unity 4

i upgraded my project from unity 3.5 to Unity 4. everything is almost OK. i can run game in editor no error when playing game, but after stopping game it give me some errors about Can’t destroy Transform component. …
all references of these errors are to .CPP files like ‘GameObjectUtility.cpp Line: 1011’

i checked all of my scripts to see whether i Dispose a Transform but nothing found. all Destroy GameObject.

so i created a simple scene with just a player and no dynamic object. running game is OK but after stopping game : sometime i give no error, sometimes 2 errors, sometimes 3 errors , …

besides i just running game and do not touch any key on keyboard or mouse to move or fire, but errors keeps happening.

i do not know another way to check scripts for debug.

any idea?

After a few months I fluky found the problem.
If you want destroy a game object, make sure that transform.parent is null.
if you forget, unity does not inform you at destroy time, but when you stop the game in editor then gives you some errors like i said in question.

It is better for unity to give better information about this type of errors.

For my case, I got this error when stop playing while instantiated frefab instance kept in reference and not released. I keep reference to manually update & destroy them. they are not released until they end their lifetime.

I tried use GameObject.Destory() in my script ’ OnDisable()/OnDestroy() function, to clean the left objects, but nothing changes.

Then DestroyImmediate() is tried and it works.