Can not log into unity hub 3.5.0

Windows 10
Unity 3.5.0
Started yesterday 7/10/2023, I could not log into Unity Hub, opens blank window 10.
I can log into Unity on the website and Assets Store,
What I have done:
Reinstalled Unity Hub 3.5.0
Emptied History and cache from Chrome and Firefox
Rebooted computer

Ubuntu 24.04
Unity 3.5.0
I can log into Unity Hub and get assets from the Assets Store

Any clues?

i could not login to the unity login system, because i had NordVPN installed, i think any VPN software causes problem, to connect to the unity login system. i had to close down the NordVPN, to be able to login, it could be your network DNS, that block the web site. check that out, Routers can have built in VPN. hope everyone find out the problem. to close down VPN worked for me.

Hi,

So When you launch the unity hub app it opens but only shows a blank screen and doesn’t load?
Is that what happens when you open unity hub 3.5.0?

Check your unity files, they might be corrupted. (If on Windows 10, Also run an SFC scan, which can be done by opening command prompt and typing in SFC /scannow)

HI,

You can try to do this:

  1. Kill all process of unity hub. In windows, you can use Task Manager。
  2. Find the cache folder and delete completely. In Windows, it could be in C:\Users\xxx\AppData\Roaming\UnityHub\
  3. Restart UnityHub and log in.

Hello All,
Thanks for the advice but I still can not get Unity Hub to sign in

What I have done:
Deleted all unity folders in:
Programs folder
AppData:
Local
Locallow
Roaming
Reinstalled Unity 3.5.0

Same issue can not login to Unity hub

I have to be missing something

Going to load Unity hub on a different window 11 laptop, not the same but it is windows and see if I have the same issue

I had the exact same issue, tried all the recommended solutions with no luck, then that’s what did the trick for me:

  1. Uninstalled Unity Hub
  2. Deleted all folders with the word “cache” in their name from all AppData paths (as @richard_j_hanson suggested above)
  3. Reinstalled Unity Hub in a different folder than previously

I’m not sure if step 2 is necessary (I had tried it before). It seems the different install folder did the trick.

Hey,
I had this issue like 2 hours ago. Now, I updated my hub to 3.6.1 and I guess it’s fixed.