Can Unity 5.3.5 work on Mac OS Yosemite

I’m about to install OSX Yosemite but I don’t know if unity works on that.
I’m currently using Mac OS Mavericks (10.9.5).
Help?

Yes, it should work.