Cannot activate GameObjects in Inspector because of a script?

A few months ago I set up the “Mobile Single Stick Control” from the Standart Assets. I got it fully worked out. Today I updated the Android SDK. Since then, all the children of the Canvas that my joystick is child of are disabled and cannot be enabled (by ticking the checkbox in the Inspector). I have narrowed it down to the MobileControlRig.cs-Script – attached to the Joystick by default – that I have attached to the canvas.

If I disable the script (or attach it to the Joystick), I can activate all the UI GameObjects but the Joystick doesn’t move the character.
If I have the script enabled, all my UI is disabled including my Joystick.
I am sure this only happened because of the SDK update since I have another computer with the exact same setup (exept for the sdk) and the stick works perfectly fine with the script attached to the canvas.

Now I can’t get the Joystick to work. I really need help with this one because I can’t really continue working on the project without being able to test it.

Thanks in advance.

Per the code of MobileControlRig.cs:

private void CheckEnableControlRig()
        {
#if MOBILE_INPUT
		EnableControlRig(true);
		#else
            EnableControlRig(false);
#endif
        }


        private void EnableControlRig(bool enabled)
        {
            foreach (Transform t in transform)
            {
                t.gameObject.SetActive(enabled);
            }
        }

also from the same script:

        // this script enables or disables the child objects of a control rig
        // depending on whether the USE_MOBILE_INPUT define is declared.

        // This define is set or unset by a menu item that is included with
        // the Cross Platform Input package.

So, if you have your canvas as a child, and EnableControlRig is false, then it’ll disable it all.

You need to enable Mobile Input Mode. If you have imported the cross platform input, you should see a menu item called “Mobile Input”, and you should have it as enabled.

On reason may no longer enable GameObject is if you restore / import an entire Mobile-specific project through “Collaborate”.

strong text
The “new” project’s build settings return to the default of Standalone. Since Standalone does not have mobile inputs, they are disabled, with an open / non-tickable checkbox in the Inspector.

Hello friend . i am facing the same issue please guide me to solve that