Cannot click 4.6 GUI when attached to a Game object

Using the 4.6 GUI I am unable to click any of the buttons under the red square.

I have been using the old GUI system for the longest time, i had decided to try and use the newer 4.6 GUI to perform this task. I started out with a canvas component attached to the square that draws the 4 buttons underneath the sprite and on runtime, it won’t click.

After I noticed that wasn’t working, I also tried to remove the canvas component, and go with a canvas and event system separate from the game object in question. when I run the game, it still won’t click. Is there anything that I am missing in this?

Also, i am running Unity 5.1.1f1 if that makes a difference.

Thanks in advance everyone.


I fear you’re not using the GUI system as intended.

  1. Add canvas
  2. Add GUI objects as children to that canvas
  3. With GUI Buttons add events to On Click.

A rigidbody on a canvas may interfere with that canvas. I’m not certain, I’ve never tried because it doesn’t make a lot of sense to have a canvas with a rigidbody, Also note that the GUI has image objects.

Again, I’d highly suggest checking out the tutorials. It looks like you’re making a board game. They have a full tutorial on making a tic-tac-toe game using only UI which may be of great help to you: