Cannot Download files to Android device (v5.3.5f1)

I am trying to Download an 300mb mp4 onto an Android phone, but the video doesn’t seem to download and I feel like I’ve tried every solution that’s on the internet.

Why isn’t this working?

Here’s what I’ve tried so far:

  1. Changing the Write Access to External (SDCard). Here’s my Player Settings:

  2. Using Application.persistentDataPath. Unfortunately when the app is on the Android, I cannot check the value of Application.persistentDataPath. On my mac, Application.persistentDataPath = "" , but I assume this changes on the Android.

  3. My AndroidManifest.xml file in /Temp/StagingArea/ has

  4. Write now I am getting the published game onto the Android by Building it and using a File Transfer tool to port it over to the Android Device. Not sure if this makes a difference.

  5. I tried changing the "jar:file://" + Application.dataPath + "!/assets/" according to the answer here(Help Writing and reading files on android. - Questions & Answers - Unity Discussions) and I’ve even tried altering that solution to use Application.persistentDataPath

Many thanks for any help given. I will be responsive as quickly as possible

I bet you resolved this like a year ago. I’m having the same issue now. What did you do?