Cannot find the length of an array

Hello! I am getting an error when I try to find the length of an array! All I am trying to accomplish with this script is spawn a random gameobject from an array. To do that I need to find the length of an array, yet for some reason Unity won’t let me do that. The error I am getting is: CS0117 UnityEngine.GameObject[] does not contain a definition for 'Length'

Here is my code, also note I have tried to just print the length of the array to the console out of the instantiate and just in the start function, it resulted in the same error.

using UnityEngine;
using System.Collections;

public class SpawnScript : MonoBehaviour {
	public GameObject[] objects;
	// runs spawn func
	void Start () {
	//spawns in a random item from an array and then does it every .5 seconds.
	void Spawn()
		Instantiate(objects[Random.Range (0, objects.Length)], transform.position, Quaternion.identity);
		Invoke ("Spawn", .5f);

Thanks for viewing (and hopefully helping)!

@bunny83 @wibble82 Yes I am sure I haven’t changed anything. I even created a new project and tried running a debug line that would just print the length of a simple array and that didn’t work. I have not “given up” on this question, I just simply don’t have anything to add. I have been trying to work with a support member. Feel free to mark the question as unreproduceable.

Works fine for me, even if the array was empty.

The only thing that comes to my mind might be some corrupted library in your project, OR …

Do you have a “GameObject” class in your project?

@benbendixon This is how I fixed the problem for myself:
Use an uppercase L in “Length” instead of a lowercase one. The unity documentation makes it seem like you should use a lowercase L, which I find weird.