Cannot launch Unity 5 (not responding)

Hi, i'm about to start playing with unity. After done installing and launch the application, it's not responding, only open first window but only show blank window screen. I'm using Win 8.1 Pro, Intel core i5 processor, 4GB RAM, NVidia GForce GT 740M VGA Card. Kindly please help ?

It's hard to tell what the problem could be. I had a similar dilemma when I downloaded Unity 4.6.3. So I deleted the application and everything linked to it, re-downloaded Unity 4.6.3 again and it worked like a charm after that. If nothing else, maybe downloading Unity 5 again might help you, although I'm not strongly recommending it because even if Unity 4.6.3 had a similar behavioural malfunction, it's not the same version as yours. That's all can give you since I'm a newbie myself.

I already tried to uninstall, but still facing the same issue.. It's so weird though, no hardware/firmware problem, and my laptop utilization is still good also. Could it be some kind of bug?

hi aye corvenuz,

just a couple of thoughts in the meantime, just in case anyone else has a few ideas, so ill throw a couple of thoughts out there for fault finding :)

tried running as administrator?
tried compatability mode (for say windows 7)?
does it state 'not responding' within window title bar after a while? is the window moveable?
is the windows notification flags anything to do with unity? (seeing theres a red X)
anything in the event log you can raise as a bug/fault?

hope you get to the bottom of it soon..

Hi OboShape,

I already tried ur suggestions, but it's still the same problem... :(
The windows itself is totally not move able and not respond..
I know the status is not responding from task manager.
But thanks for ur reply though..

Sorry :(

hope you manage to get an answer and get it going.