Cannot log in Unity Hub 3 on Ubuntu (xdg-open fails)


I am trying to use Unity Hub 3.0.0-beta.5 on Ubuntu 20, but I a stuck at the login step.
The sign-in button opens a browser page, I log in, but I then get an empty page and nothing happens.

I think the xdg-open redirection fails, maybe because Unity Hub is an AppImage?
Do you have any suggestions on how to fix this, maybe by passing some CLI arguments to the AppImage?

Thank you for your help

Alright. I have found a solution to login:

  1. I assume you have downloaded the UnityHubBeta and started it, you have already created a account and are logged into the Unity account on your default browser.
  2. Click on ‘sign in’ in the UnityHub, your system should now open a link ‘…’ in your default browser.
  3. Now cancel the xdg-open request and press F12 (open dev tools). In the HTML there should be a <meta http-equiv="refresh" ... > tag.
  4. Copy the value of the attribute ‘content’. It should look a bit like this: unityhub://login/?code=0Q...8f&locale=en&session_state=c5...1bf
  5. Now switch to the terminal and navigate to the UnityHubBeta.AppImage and run it with ./UnityHubBeta.AppImage unityhub://login/?code=0Q...8f&locale=en&session_state=c5...1bf


  • It takes some time until you’re logged in and until the Hub opens.
  • I tried some other things before it worked. Let me know if the instructions above don’t work.

*Old Solution*

@extrasugarrr As a (temporary) fix you can use:

  1. Install Unity from ‘this page’.
  2. Scroll down to the last post (or the version you want) and download the unity setup.
  3. To run it, change the permission of the file to be executable (Right click → permissions) and then run ./UnitySetup
  4. To start again, navigate to the installation folder and then Editor (Example: ~/Unity-2019.4.0f1/Editor) and run ./Unity

This is though only a band-aid fix, since I can’t publish my builds, because you need to be logged in.

Same Here. I’m on Ubuntu 21 and I can’t get it to sign me in.
I tried logging in and signing up with a google account and not even that works. It just sits there with a blank page. Maybe if the editors were not hidden behind the hub’s launcher, we could at least skip and go directly to that until the issue gets fixed.