Cannot move 2D object no matter what I do

Hello, I’m trying my darnest to figure out the 2d Unity engine.

My current setup was supposed to be the basics that I would then start building off of. It’s literally a single 2d object that I’m using as a player object, and I wrote a pretty standard control movement script using transform.position rather than RigidBody to move it, due to the specifics of the game I’m working on.

But nothing happened. No matter what I’ve tried, I can’t get the dang thing to move an inch. Even a 1 line script that should automatically move the object has done nothing. I’ve watched several tutorials, looked over forums, and have found nothing. Help???

[merged reply below]

I tried a similar script in a 3d version of the project with everything else the same, and it worked perfectly so I’m not sure what the issue is.

using System.Collections;
using System.Collections.Generic;
using UnityEngine;

public class isodude_4_controller : MonoBehaviour
{
    void update()
    {
        transform.position += new Vector3(0, 1, 0);
    }   
}

In C#, methods are named with PascalCase, and Unity doesn’t recognize methods unless you use proper casing.
It needs to be Update, not update.

This provided script should work. Did you attach it to the object, and entered play mode?