Cannot open projects, Unity cannot find metadata

I started having this issue in Unity 5.6, starting a new project was fine, I encountered the error while trying to switch my build settings. Dumbly assumed it was because I had Unity installed on a non-boot exFat drive with weird permissions, so I reinstalled 2017.3 on my boot drive and deleted unity off my exFat drive. There are some random folders called “Unity” on various hard drives that are full of these ugly numbered metadata files, but that inside of project folders, and some of them are empty and and some of them are full. (My computer is a million years old and a mess.)

I now cannot open any old projects or start any new projects. I get this error “Opening file /Users/User/Documents/Unity2/Project/library/metadata/00/ No such file or directory”.

If I hit cancel it creates those extra numbered .info files in the folder you can see in the screen shot.

I have tried:

  • restarting

  • reinstalling unity

  • List item

  • deleting the metadata folder

  • deleting the temp folder

  • prayer

Thanks in advance

I have no idea why, but relocated every Unity project on my computer so that the Recent Project list was empty solved this issue. Hopefully this helps someone else.