Cannot Set Array Size in Inspector

Just as the name implies, I cannot set any array size in the inspector. I first noticed this happen in a project for the Unity Asset Store I was working on. I thought it was my custom class causing problems, but even simple classes and data types aren’t working.

This is my test code:
public class ArrayTest : MonoBehaviour {
public int MyIntArray;
}
It’s a simple script I made to try and remove any interaction with other scripts.
Testing in an empty project (except for this one script).
Tried resetting script.
Tried re importing assets.

Running in Unity 5.0 and in Unity 5.1
Arrays worked for both versions previously.

Please help,
Thanks

Project settings might have messed up. Create a new project and transfer all the assets there. See if there is the same problem. Maybe you have an editor script which handles all components?

OH MY GOD I FIXED IT I’M SO EMBARRASSED

The issue was that my numlock had been turned off (I use numpad for inputing numbers exclusively). I tried with the normal number keys and then turned num lock back on and it all works.

Huge thanks to everyone who tried to help out, can’t believe it was something so simple XD