'Cannot Submit Change to Server' and Failing to Revert Project in Unity Collab

I was working on my Unity Project normally with Collab on, and I happened to copy a Folder which contained a .cs file which had exactly the same name of another .cs file. I immediately spotted the error and proceeded to delete the folder. After deleting the folder successfully and attempting to Publish Changes on unity collab, it fails and I instead receive an error ‘Cannot submit change to server’.
After reading multiple forum posts, I have tried deleting the CollabSnapshot file which still did not fix it, and I also tried reverting and Go Back To… which all fail as well and return ‘Operation Failed’.

Could anyone please help out? I have heard that it may have something to do with my file having the same name, and would really appreciate any help! This is really urgent, and I seriously cannot afford to lose my project.

The above is the error I get when trying to Publish Now

The above image is the error I get when trying to Revert my project or Go Back To…

Thank you very much to whoever can help!

My Unity Version is V2018.3.5f1


Update: Unity Collab Just Begun
Functioning By Itself and fixed the